Start a new topic

Can't connect external GNSS via Bluetooth


thank you for this amazing app. I wanted to use it in my field research, however I've run into this little problem. It seems I can't connect my Garmin GPSMAP 65 as an external GNSS via Bluetooth.

I tried these things:

1) When launching the app, I opened the GPS devices manager and clicked the "+" button. Then I selected "Bluetooth 3" -> "GPS device" -> "GPSMAP 65". The device appears in the manager, however it doesn't seem to connect. There is a message next to the "Disconnect" button saying "Searching..." and after a while it changes to "Sensor disconnected". After that, "Searching" appears once more and the whole things repeats in an infinite loop.

2) I tried clicking the "Disconnect" button and then the "Connect" button. Still the same - "Searching..." -> "Sensor disconnected".

3) I tried disconnecting my device from the Garmin Explore app. I even proceeded to uninstall the app. Then I deleted the device from LocusGIS and tried connecting it once again - to no positive result, it still says "Searching..." and "Sensor disconnected".

4) I also tried to reinstall LocusGIS (deleting the data in the process), but the problem remains.

In all the cases I also checked the satellite screen, making sure that I set the GPSMAP 65 as the source of the data - it says "No satellites".

Is there anything else I could do to solve the problem?

Thank you so much.

1 Comment

Hi Tomáš,

thank you for the report and the detailed description. Honestly, I'm not familiar with the GPSMAP 65, but are you sure this device can be used as an external Bluetooth GPS? I have quickly checked its capabilities and have not found any information that the device can be connected as an external GPS. Could I kindly ask you to check the manual or the device specification if it can user as an external GPS?

Thanks, Petr

Login or Signup to post a comment