Start a new topic

Cannot stop tracklog

I've started a tracklog and with 6967 tracklog points Locus cannot stop/save the track. I hit the stop button, Locus says "Working", but seconds later Locus closes, home screen appears. Locus icon is still on the notification bar, and I can open it, but it seems that tracklog continues, like nothing happened. I've tried several times to stop tracklog, but the same happens every time. I've disabled every other layers, uninstalled unnecessary apps, cleared the device memory to free up extra memory, but 6967 tracklog points are just way too much for the device to handle. Any help or suggestions in SOS?

Gosh, I can't believe it, right after I submitted my post, the next try was successful. I swear to you, I've spent many hours repeating the stopping process unsuccessfully. Anyway, I had the same issue a few days ago when I had similar amount of tracklog points and I had to try many times to succeed. Device is Xiaomi Mi A2 Lite 3Gb RAM, Android 10


the saving proces can really take couple minutes if there are thousands points in recorded track.  Anyway as usually we would need to simulate it. Could you see the "Working" progress when you clicked on the stop button? 

Thanks, Petr

Yes, "Working" progress appears, the loading line moves. After about 20 seconds, Locus  exits (or minimalizes), and the recording icon is still on the notification bar, meaning it's not "lost", but perhaps Locus ignored the "stop" command. I cannot reproduce the issue, as luckily Locus finally managed to stop the recording, and I could save the track.

But I'm sure it will happen  again when I'm recording a detailed/long track with 5-6000+ trackpoints.

Locus GIS was very likely really processing the points if there was a working dialog. On the other side, it shouldn't take hours but only minutes. Please test it or change the recording profile to reduce the number of recorded points (if possible to use less detailed recording)

Yesterday I recorded a new tracklog, with 5263 tracklog points, and I cannot stop and save it as well. I could retry after every failure, but repeating the process without success is a bit frustrating. Nevermind, hopefully it will manage to stop and save the track some time. :) Maybe I could create a bug report for you to see if there's any real issue, or just the hardware memory isn't enough for such amount of tracklog points to process.

Thank you for the bug report. What does exactly happen when you tap on the STOP button? Does dialog "App not responding" appear? If yes, would you tap on option wait?

To simulate saving of several thousands points: open menu > Settings > Track recording > tap on detailed profile:

- set Time Interval to 1s

- edit  "Vertex recording condition" > and set option "Distance OR Time"

After that start recording of the new Line. You can put  device close to window for an hour. It should record new point every second. Finally try to save the line.

Thank you


After I tap on the Stop button, tracklog sidebar shifts back, and "Waiting" dialog ppears with the moving "loading" line. Then, after a few seconds, Locus disappears (or minimizes). Then I can reopen locus from notification bar again, but it seems like nothing happened, treacklog recording is still pending.

I've uploaded a recorded screen video:

Time interval was set to 1 sec already, I've set the recording condition to distance OR time. But what do you mean by recording "new" line? I cannot record a new line, as I'm already recording a line, and I cannot stop it. Actually there isn't any option to cancel the recording, the only option is to stop the recording, which ends up as I described. Maybe I could restart the device, or force kill the app, so eventually it would forget (and lose) the recording, but that's not the goal. I would like to save the tracklog somehow. Anyway, I tried with this setting, it recorded new tracklog points (added to the 5263 points), but the same issue, after a while, app exits to home screen.

Thank you for the video you provided. We'll try to find some improvements.

I found this quite old but still not solved issue. Are you still facing mentioned troubles, please?
Thanks, Petr

 Issue "solved" . The problem was that my old device could not handle such huge amount of data to process, and freezed during saving. Using a more powerful device solved the issue. Thakns!

Ahh I see, thanks.

Login or Signup to post a comment