Start a new topic

Snapping not works

Hi, i´m trying to use the option snap (iman) but it not works. Thaks

Best Answer

Thank you for detailed description. And please feel free to contact us if you're able to simulate it. 


I'm sorry but could I kindly ask you for more info, please? How is the new point created, please? Do you select point on the map or is it created based on your current location, please? The snapping is ignored when point is created based on your location?

Thansk, Petr

I think I had the similar problem. I tried to recreate it but it is hard, but my thought about it is this, if you have corrupt shapefile with corrupted transformation of projections or have a badly exported raster underneath, those kinds of bugs like bad snapping or features not showing are expected to happen. So make sure everytime you work with the app that you have a working stable shapefile and you export to MBTiles for the raster is the same projection and it is not badly transformed or corropted in any other way. Good luck with your work.

@Darko - are you able to simulate it, please? Would be possible to create a short video that record your steps to simulate this issue? I can suggest the app AZ Screen Recorder for screen recording

Anyway, the snapping is not related to the raster layer at all, only the position of the lines/points affects the snapping.

1 person likes this

I am afraid I can't replicate the same thing again, all I can do is give you and others a bit more explanation, as this happened only once. I export as a raster google satellite from the QuickMapServices plugin in Qgis that I had to change projections to so it has the same projection as my shapefiles. And it wasn't a thing that happened all the time. Usually, after some while what you see on the screenshot happens and the bug disappears without me restarting the app or the phone and this was happening untill I finished the project. Next time when I used the app I exported other rasters(not from QuickMapServices) and everything worked just fine. That is why I had the assumption that maybe the raster has something to do with it, but I won't be surprised that the shapefiles were corrupted or something. If it ever happens again I will be happy to screen-record it and send more explanation about it. Sadly I don't have the project on my phone or pc, but if I somehow find a backup of it, I will try to replicate the bug or send a copy of the project to you so you can check it out. That is all I have for now.


Thank you for detailed description. And please feel free to contact us if you're able to simulate it. 

Login or Signup to post a comment